GitHub header

EU - Some data not showing in Elastic Search indexes

Incident Report for GitHub Enterprise Cloud - EU

Resolved

On April 23, 2026 between 23:32 and 01:20 UTC, GitHub Issues and Issues Advanced Search experienced degraded availability in a GHEC DR environment due to a unintentional storage node removal in our Elasticsearch cluster during a routine OS upgrade. 2.9% of searches in this environment failed during this period.

We restored the affected indexes from a backup and brought the index up to date. We are adding additional automation and safeguards to our maintenance processes to prevent this type of incident happening again
Posted Apr 24, 2026 - 01:20 UTC

Update

Issues is operating normally.
Posted Apr 24, 2026 - 01:16 UTC

Update

We have identified the issue with missing search data and are working to restore it.
Posted Apr 24, 2026 - 00:51 UTC

Update

Issues is experiencing degraded availability. We are continuing to investigate.
Posted Apr 24, 2026 - 00:33 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Apr 23, 2026 - 23:58 UTC
This incident affected: Issues.