This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 19, 2026 - 14:32 UTC
Monitoring
Copilot is operating normally.
Posted Mar 19, 2026 - 14:32 UTC
Update
We are investigating reports that Copilot Coding Agent session logs are not available in the UI.
Posted Mar 19, 2026 - 14:02 UTC
Update
Copilot is experiencing degraded performance. We are continuing to investigate.
Posted Mar 19, 2026 - 13:45 UTC
Update
We are investigating reports of Copilot coding agent session logs not loading and sessions intermittently not starting. Users are able to see their tasks and create new ones.
Posted Mar 19, 2026 - 12:32 UTC
Update
We have resolved the underlying credential issue and have verified that users can see and interact with their Copilot Coding Agent tasks.
We are now investigating issues with some Coding Agent tasks completing successfully.
Posted Mar 19, 2026 - 12:00 UTC
Update
We believe we have identified an underlying credential issue and are working to resolve that across impacted environments.
Posted Mar 19, 2026 - 11:19 UTC
Update
We are investigating reports of errors when accessing Copilot Coding Agent features. Users may be unable to view or start coding agent tasks through the Agents interface. Our engineers are actively working to restore full functionality.
Posted Mar 19, 2026 - 10:43 UTC
Investigating
We are investigating reports of impacted performance for some GitHub services.