GitHub header

EU - Incident with Copilot

Incident Report for GitHub Enterprise Cloud - EU

Resolved

On February 23, 2026, between 14:45 UTC and 16:19 UTC, the Copilot service was degraded for Claude Haiku 4.5 model. On average, 6% of the requests to this model failed due to an issue with an upstream provider. During this period, automated model degradation notifications directed affected users to alternative models. No other models were impacted. The upstream provider identified and resolved the issue on their end.
We are working to improve automatic model failover mechanisms to reduce our time to mitigation of issues like this one in the future.
Posted Feb 23, 2026 - 16:19 UTC

Update

Copilot is operating normally.
Posted Feb 23, 2026 - 16:00 UTC

Investigating

We are investigating reports of degraded performance for Copilot
Posted Feb 23, 2026 - 14:56 UTC
This incident affected: Copilot.