On January 8th, 2026, between 04:00 UTC and 12:44 UTC multiple GitHub services were partially degraded and had delayed response times or returned errors. The error rate was low throughout the incident, peaking at 2.65% of requests for customers of GitHub Enterprise Cloud with Data Residency in the EU. This was due to a degradation in one of our underlying infrastructure providers.
The incident was mitigated by partially draining the degraded infrastructure and escalating with the provider. In order to address these types of issues more promptly in the future we have tuned the sensitivity of our monitoring in this area and updated our escalation policies accordingly. We are also implementing improvements to better isolate and limit the impact of partial infrastructure degradations.
Posted Jan 08, 2026 - 13:08 UTC
Update
We're beginning to see recovery across multiple services and will continue to monitor.
Posted Jan 08, 2026 - 12:52 UTC
Update
We are seeing intermittent failures broadly impacting services due to an ongoing networking issue.
Posted Jan 08, 2026 - 12:11 UTC
Update
We're investigating issues impacting multiple services resulting in intermittent errors.
Posted Jan 08, 2026 - 11:58 UTC
Investigating
We are investigating reports of degraded performance for Actions