On February 12th, 2025, between 21:30 UTC and 23:10 UTC the Copilot service was degraded and all requests to Claude 3.5 Sonnet were failing. No other models were impacted.
This was due to an issue with our upstream provider which was detected within 12 minutes, at which point we raised the issue to our provider to remediate. GitHub is working with our provider to improve the resiliency of the service.
Posted Feb 12, 2025 - 23:10 UTC
Update
Claude Sonnet is fully available in GitHub Copilot again. If you used an alternate model during the outage, you can switch back to Claude Sonnet.
Posted Feb 12, 2025 - 23:10 UTC
Update
We are seeing a recovery with our Claude Sonnet model provider. We'll confirm once the problem is fully resolved.
Posted Feb 12, 2025 - 23:04 UTC
Update
Our Claude Sonnet provider acknowledged the issue. They will provide us with next update by 11:30 AM UTC / 3:30 PM PT. Claude Sonnet remains unavailable in GitHub Copilot, please use an alternate model.
Posted Feb 12, 2025 - 22:54 UTC
Update
We escalated the issue to our Claude Sonnet model provider. Claude Sonnet remains unavailable in GitHub Copilot, please use an alternate model.
Posted Feb 12, 2025 - 22:41 UTC
Investigating
We are investigating reports of degraded performance for Copilot