GitHub header
Incident with Pull Requests, Pages and Actions
Incident Report for GitHub Enterprise Cloud - EU
Resolved
On August 14, 2024 between 23:02 UTC and 23:38 UTC, all GitHub services were inaccessible for all users.

This was due to a configuration change that impacted traffic routing within our database infrastructure, resulting in critical services unexpectedly losing database connectivity. There was no data loss or corruption during this incident.

We mitigated the incident by reverting the change and confirming restored connectivity to our databases. At 23:38 UTC, traffic resumed and all services recovered to full health. Out of an abundance of caution, we continued to monitor before resolving the incident at 00:30 UTC on August 15th, 2024.

We will provide more details as our investigation proceeds and will post additional updates in the coming days.
Posted Aug 15, 2024 - 00:30 UTC
Update
Git Operations is operating normally.
Posted Aug 15, 2024 - 00:13 UTC
Update
The database infrastructure change is being rolled back. We are seeing improvements in service health and are monitoring for full recovery.
Posted Aug 14, 2024 - 23:45 UTC
Update
We are experiencing interruptions in multiple public GitHub services. We suspect the impact is due to a database infrastructure related change that we are working on rolling back.
Posted Aug 14, 2024 - 23:29 UTC
Update
Git Operations is experiencing degraded availability. We are continuing to investigate.
Posted Aug 14, 2024 - 23:19 UTC
Update
We are investigating reports of issues with GitHub.com and GitHub API. We will continue to keep users updated on progress towards mitigation.
Posted Aug 14, 2024 - 23:16 UTC
Investigating
We are currently investigating this issue.
Posted Aug 14, 2024 - 23:13 UTC
This incident affected: Git Operations.