GitHub header
We are investigating reports of degraded performance.
Incident Report for GitHub Enterprise Cloud - EU
Resolved
On June 5, 2024, between 17:05 UTC and 19:27 UTC, the GitHub Issues service was degraded. During that time, no events related to projects were displayed on issue timelines. These events indicate when an issue was added to or removed from a project and when their status changed within a project. The data couldn’t be loaded due to a misconfiguration of the service backing these events. This happened after a scheduled secret rotation when the wrongly configured service continued using the old secrets which had expired.

We mitigated the incident by remediating the service configuration and have started simplifying the configuration to avoid similar misconfigurations in the future.
Posted Jun 05, 2024 - 19:27 UTC
Investigating
We are currently investigating this issue.
Posted Jun 05, 2024 - 17:22 UTC