GitHub header

EU - Incident with Actions

Incident Report for GitHub Enterprise Cloud - EU

Resolved

On July 9th, 2025, between 14:20 UTC and 16:56 UTC, GitHub Actions was degraded. During this period, 2% of in-progress workflow runs failed and 21% workflow runs failed to start. This incident was caused by a deployment issue where a failed update to our container infrastructure prevented some of the service instances from restarting properly, resulting in reduced capacity in one of the core Actions services. We are implementing safeguards to prevent this failure mode and have added additional monitoring to reduce detection and mitigation time for similar incidents in the future.
Posted Jul 09, 2025 - 16:52 UTC

Update

Actions is operating normally.
Posted Jul 09, 2025 - 16:51 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Jul 09, 2025 - 16:31 UTC
This incident affected: Actions.